Back to overview
Degraded

Degraded Performance Due to Cloudflare CDN Outage

Nov 18 at 12:15pm UTC
Affected services
Javascript SDK
Web Application
Web Application & Chrome Extension APIs
Userpilot Website

Resolved
Nov 18 at 12:53pm UTC

We have switched CDN providers temporarily. Our services are no longer affected by Cloudflare’s outage and are functioning normally.

Thank you for your patience and understanding.

Updated
Nov 18 at 12:18pm UTC

The issue affecting our Web Application & Chrome Extension APIs has now been fully resolved, and the app is loading normally again.

We are still actively investigating the remaining impact related to our JavaScript SDK and other static assets that continue to be affected by the Cloudflare CDN outage. Some customers may still experience intermittent slowdowns or timeouts when loading these resources.

We will share further updates as soon as we have more information. Thank you for your patience and understanding.

Created
Nov 18 at 12:15pm UTC

We are currently experiencing a service degradation due to an ongoing outage at our CDN provider, Cloudflare.
This may affect both the loading of our web application and the download of our JavaScript SDK.

Impact:

Some customers may be unable to load the web app or may experience very slow load times.
Some customers may experience failures or timeouts when downloading our SDK.
Impact may vary by region and ISP depending on Cloudflare’s edge availability.
What’s happening:

Our assets (including the SDK and static web resources) are served through Cloudflare. As Cloudflare is currently having issues, some requests to these assets are failing or timing out.