Back to overview
Degraded
EU Region Service Degradation
Jun 10, 2026 at 4:00pm UTC
Affected services
Event Ingestion (EU)
Web Application
Resolved
Jun 10, 2026 at 4:28pm UTC
The issue has been resolved, and everything is working normally now. Thank you for your patience.
Affected services
Updated
Jun 10, 2026 at 4:15pm UTC
The issue has been identified and a fix has been deployed. Services in the EU region have recovered and are operating normally. We will continue to monitor the system to ensure stability.
Affected services
Created
Jun 10, 2026 at 4:00pm UTC
We are currently experiencing an issue affecting our EU hosting region. Our team is actively working on a fix and will share updates as they become available.
Affected services