Back to overview
Resolved

EU Region Service Degradation

Jul 4, 2026 at 10:50am UTC
Affected services
Event Ingestion (EU)

Resolved
Jul 4, 2026 at 11:40am UTC

As a follow-up, we isolated the affected subsystem under its own supervisor so that any similar external change or failure will be contained without affecting regional service availability.

Updated
Jul 4, 2026 at 11:31am UTC

A fix has been deployed to the EU region. Wildcard certificates now verify correctly and application instances are starting normally. We are monitoring.

Updated
Jul 4, 2026 at 11:10am UTC

The issue has been identified: Firebase (FCM) rotated the TLS certificate on their endpoint to a wildcard certificate, and our TLS handshake failed to verify it. The failed connections caused application instances in the EU region to crash on startup.

Created
Jul 4, 2026 at 10:50am UTC

We are investigating a service degradation in the EU region.